aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-02-11 16:25:59 +0100
committerAndreas Schneider <asn@cryptomilk.org>2013-02-11 16:25:59 +0100
commit0318566ef68991c4a4a436b8e45b6b15e59cc7a5 (patch)
tree75876de033a3aaf2505e028919dab2d42c56aa97 /CMakeLists.txt
parentd3976815ea931037f92bd361e4a9f7764aac89c5 (diff)
downloadcmocka-0318566ef68991c4a4a436b8e45b6b15e59cc7a5.tar.gz
cmocka-0318566ef68991c4a4a436b8e45b6b15e59cc7a5.tar.xz
cmocka-0318566ef68991c4a4a436b8e45b6b15e59cc7a5.zip
cmake: Add pkgconfig file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6cfb89..8d1e74a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,3 +54,14 @@ add_subdirectory(src)
if (UNIT_TESTING)
add_subdirectory(example)
endif (UNIT_TESTING)
+
+# pkg-config file
+configure_file(cmocka.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/cmocka.pc)
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/cmocka.pc
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig
+ COMPONENT
+ pkgconfig
+)