aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2014-08-07 13:29:33 +0200
committerAndreas Schneider <asn@cryptomilk.org>2014-08-07 13:30:07 +0200
commit2487f7ad732b7f62605b14a1d9520ff68cb17054 (patch)
tree1e23cd3b851dc0017b55e802c56b99e3ca066399 /CMakeLists.txt
parenta083c088b60dd2055bc6d852635b9589d62b6bc1 (diff)
downloadcmocka-2487f7ad732b7f62605b14a1d9520ff68cb17054.tar.gz
cmocka-2487f7ad732b7f62605b14a1d9520ff68cb17054.tar.xz
cmocka-2487f7ad732b7f62605b14a1d9520ff68cb17054.zip
cmake: Use standard cmake variables in CMakeLists.txt.
Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e80fdbc..f3a2991 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,7 @@ install(
)
# cmake config files
-set(CMOCKA_LIBRARY_NAME @CMAKE_SHARED_LIBRARY_PREFIX@${PROJECT_NAME}@CMAKE_SHARED_LIBRARY_SUFFIX@)
+set(CMOCKA_LIBRARY_NAME ${CMAKE_SHARED_LIBRARY_PREFIX}${PROJECT_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
configure_file(${PROJECT_NAME}-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config.cmake @ONLY)
configure_file(${PROJECT_NAME}-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config-version.cmake @ONLY)