aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2014-01-20 23:39:19 +0100
committerAndreas Schneider <asn@cryptomilk.org>2014-01-20 23:39:19 +0100
commit3770c5dc8f0718d849eb1d73c29c0b33db253c49 (patch)
treedaa16310c552ef96e040aea17130e6fb23d29311 /CMakeLists.txt
parent11df27bbf33664611840abca158d4f75e79eaa0b (diff)
downloadcmocka-3770c5dc8f0718d849eb1d73c29c0b33db253c49.tar.gz
cmocka-3770c5dc8f0718d849eb1d73c29c0b33db253c49.tar.xz
cmocka-3770c5dc8f0718d849eb1d73c29c0b33db253c49.zip
cmake: Add cmake config mode support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9952c4a..7752d78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,3 +65,16 @@ install(
COMPONENT
pkgconfig
)
+
+# cmake config files
+configure_file(cmocka-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cmocka-config.cmake @ONLY)
+configure_file(cmocka-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cmocka-config-version.cmake @ONLY)
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/cmocka-config.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/cmocka-config-version.cmake
+ DESTINATION
+ ${CMAKE_INSTALL_DIR}
+ COMPONENT
+ devel
+)