aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-12-23 16:00:07 +0100
committerAndreas Schneider <asn@cryptomilk.org>2013-12-23 16:00:07 +0100
commit3fca34362115c256fffce3dd68ff878c86153c95 (patch)
tree9110b50243fd614a6e829c765d3e107ae6d3b776 /CMakeLists.txt
parent417b92df7023a32c0b2775d59f1816b629e0a9b9 (diff)
downloadcmocka-3fca34362115c256fffce3dd68ff878c86153c95.tar.gz
cmocka-3fca34362115c256fffce3dd68ff878c86153c95.tar.xz
cmocka-3fca34362115c256fffce3dd68ff878c86153c95.zip
tests: Add test_assert_macros.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7926cee..ea9b392 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,10 +35,6 @@ include(DefineInstallationPaths)
include(DefineOptions.cmake)
include(CPackConfig.cmake)
-if (UNIT_TESTING)
- include(AddCMockaTest)
-endif (UNIT_TESTING)
-
# disallow in-source build
include(MacroEnsureOutOfSourceBuild)
macro_ensure_out_of_source_build("${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there.")
@@ -51,8 +47,11 @@ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
add_subdirectory(doc)
add_subdirectory(include)
add_subdirectory(src)
+add_subdirectory(example)
+
if (UNIT_TESTING)
- add_subdirectory(example)
+ include(AddCMockaTest)
+ add_subdirectory(tests)
endif (UNIT_TESTING)
# pkg-config file