aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2012-10-09 12:49:52 +0200
committerAndreas Schneider <asn@cryptomilk.org>2012-10-09 12:49:52 +0200
commitbb257053b2909bcd42b288f31a3048d55ffeaf42 (patch)
tree67355a0287cf08bba19d756d2da6d209dfdfbd41 /CMakeLists.txt
parentf3f90437f8f6ccab489b0b1a891bb3bd4c84b9ff (diff)
downloadcmocka-bb257053b2909bcd42b288f31a3048d55ffeaf42.tar.gz
cmocka-bb257053b2909bcd42b288f31a3048d55ffeaf42.tar.xz
cmocka-bb257053b2909bcd42b288f31a3048d55ffeaf42.zip
cmake: Add ctest support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9667171..63b16b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,10 @@ include(DefineInstallationPaths)
include(DefineOptions.cmake)
include(CPackConfig.cmake)
+if (UNIT_TESTING)
+ include(AddCMockaTest)
+endif (UNIT_TESTING)
+
# disallow in-source build
include(MacroEnsureOutOfSourceBuild)
macro_ensure_out_of_source_build("${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there.")