aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Ates <joseph.ates@msasafety.com>2016-01-23 05:14:04 -0500
committerAndreas Schneider <asn@cryptomilk.org>2016-02-10 13:25:20 +0100
commitc35d3edecac0b5e5884f9e26ba9cf73753279ea3 (patch)
tree78556040913336b52db01f7e5ebca035982223bf /CMakeLists.txt
parentf8bba4b3a519147de59a2a7c3dc6262549e7e2bb (diff)
downloadcmocka-c35d3edecac0b5e5884f9e26ba9cf73753279ea3.tar.gz
cmocka-c35d3edecac0b5e5884f9e26ba9cf73753279ea3.tar.xz
cmocka-c35d3edecac0b5e5884f9e26ba9cf73753279ea3.zip
cmocka: Add VS2015 support
Visual Studio now includes support for vsnprintf and snprintf but does so as an inline functions. check_symbol_exists is used to check for its existence within stdio. [3] All tests are passing when run from within the IDE or via NMake. Command line builds via msbuild seem to error for the first few example tests. Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70a8ad1..4507444 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,7 @@ include(DefineCompilerFlags)
include(DefineInstallationPaths)
include(DefineOptions.cmake)
include(CPackConfig.cmake)
+include(CheckSymbolExists)
# disallow in-source build
include(MacroEnsureOutOfSourceBuild)