aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2019-01-23 11:20:31 +0100
committerAndreas Schneider <asn@cryptomilk.org>2019-01-23 11:20:31 +0100
commitee264da1aa222b354cee36184ab48c2072f62243 (patch)
treef69e5f0639ee69d7f6502797348713ed3359aa97 /CMakeLists.txt
parent092e17f0db2d9507462b9ca7893f2434073f3e1e (diff)
downloadcmocka-ee264da1aa222b354cee36184ab48c2072f62243.tar.gz
cmocka-ee264da1aa222b354cee36184ab48c2072f62243.tar.xz
cmocka-ee264da1aa222b354cee36184ab48c2072f62243.zip
cmake: Add WITH_EXAMPLES options
This is turned on by default, but you can disable it, if you just package cmocka for an opterating system. Fixes #14 Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7778039..702be97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,9 @@ if (UNIT_TESTING)
add_subdirectory(tests)
endif (UNIT_TESTING)
-add_subdirectory(example)
+if (WITH_EXAMPLES)
+ add_subdirectory(example)
+endif ()
# pkg-config file
configure_file(cmocka.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/cmocka.pc)