aboutsummaryrefslogtreecommitdiff
path: root/example/chef_wrap/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2015-02-12 09:14:10 +0100
committerAndreas Schneider <asn@cryptomilk.org>2015-02-12 16:59:22 +0100
commit8798b43ea565927b3dbdc387cd0649dc422cdcd8 (patch)
treee5e79218939830df73cb520d742ffa04c4fe247f /example/chef_wrap/CMakeLists.txt
parentc180601e564bcbf2ec2d143963ca22a3effdb9fe (diff)
downloadcmocka-8798b43ea565927b3dbdc387cd0649dc422cdcd8.tar.gz
cmocka-8798b43ea565927b3dbdc387cd0649dc422cdcd8.tar.xz
cmocka-8798b43ea565927b3dbdc387cd0649dc422cdcd8.zip
cmake: Fix executing test examples on Windows.
The executable need the path to dll set so they can be run successfully. Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'example/chef_wrap/CMakeLists.txt')
-rw-r--r--example/chef_wrap/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/example/chef_wrap/CMakeLists.txt b/example/chef_wrap/CMakeLists.txt
index 60d5a36..5902438 100644
--- a/example/chef_wrap/CMakeLists.txt
+++ b/example/chef_wrap/CMakeLists.txt
@@ -15,3 +15,6 @@ set_target_properties(waiter_test_wrap
PROPERTIES
LINK_FLAGS "-Wl,--wrap=chef_cook"
)
+if (WIN32)
+ set_tests_properties(waiter_test_wrap PROPERTIES ENVIRONMENT "PATH=${DLL_PATH_ENV}")
+endif (WIN32)