aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2018-09-26 17:20:44 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-09-27 13:35:39 +0200
commitd1b260702b2a0aea9882c8047a8f2508230fe8b8 (patch)
tree3ea88168612acf0fdba232e2de09f6bd051da94a /src/CMakeLists.txt
parente1378cef7ca6f22175671fa3af300bc6da496988 (diff)
downloadcmocka-d1b260702b2a0aea9882c8047a8f2508230fe8b8.tar.gz
cmocka-d1b260702b2a0aea9882c8047a8f2508230fe8b8.tar.xz
cmocka-d1b260702b2a0aea9882c8047a8f2508230fe8b8.zip
cmake: Fix CMOCKA_DLL_PATH for Windows
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 49c9205..782fefd 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -119,20 +119,3 @@ if (BUILD_STATIC_LIB)
${PROJECT_NAME})
endif()
endif (BUILD_STATIC_LIB)
-
-if (WIN32)
- if (POLICY CMP0026)
- cmake_policy(SET CMP0026 OLD)
- endif()
-
-#
-# In order to run tests we will need to set the approriate environment
-# variable so that the test program can locate its dependent DLL's. First
-# we want to know what directory our dependent DLL was installed into:
-#
- get_target_property(_cmocka_dir cmocka_shared LOCATION_${CMOCKA_BUILD_TYPE})
- get_filename_component(_cmocka_path "${_cmocka_dir}" PATH)
- file(TO_NATIVE_PATH "${_cmocka_path}" _cmocka_path_native)
-
- set(CMOCKA_DLL_PATH "${_cmocka_path_native}" PARENT_SCOPE)
-endif()