aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2012-10-09 12:41:53 +0200
committerAndreas Schneider <asn@cryptomilk.org>2012-10-09 12:41:53 +0200
commitf3f90437f8f6ccab489b0b1a891bb3bd4c84b9ff (patch)
treed6b64e7fe915ef8fff9cc7b89931611c5140a395 /src/CMakeLists.txt
parente0326ea1a37bb5e617b74447bee3d4dc9dac7328 (diff)
downloadcmocka-f3f90437f8f6ccab489b0b1a891bb3bd4c84b9ff.tar.gz
cmocka-f3f90437f8f6ccab489b0b1a891bb3bd4c84b9ff.tar.xz
cmocka-f3f90437f8f6ccab489b0b1a891bb3bd4c84b9ff.zip
cmake: Add an option to turn on unit testing.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8390d60..f4bd555 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -91,4 +91,6 @@ if (WITH_STATIC_LIB)
endif (WITH_STATIC_LIB)
add_subdirectory(include)
-add_subdirectory(example)
+if (UNIT_TESTING)
+ add_subdirectory(example)
+endif (UNIT_TESTING)