aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2018-11-22 17:04:20 +0100
committerAndreas Schneider <asn@cryptomilk.org>2018-11-23 21:00:05 +0100
commitfee213a156a90443864be117cbd77cd31be9d0ef (patch)
tree612d2628c8928b782a7becc7a8c9a897015e3c74 /src/CMakeLists.txt
parent2af6e52259bfd0cc7711aefbc20ce45fa90f788d (diff)
downloadcmocka-fee213a156a90443864be117cbd77cd31be9d0ef.tar.gz
cmocka-fee213a156a90443864be117cbd77cd31be9d0ef.tar.xz
cmocka-fee213a156a90443864be117cbd77cd31be9d0ef.zip
cmake: Add runtime destination to cmocka installation
If "RUNTIME DESTINATION" is not provided in install(), the generated *.dll files are not installed in Windows because they are treated as runtime artifacts. Fixes #13 Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e44ef40..5684685 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -78,6 +78,8 @@ install(TARGETS
${CMAKE_INSTALL_LIBDIR}
LIBRARY DESTINATION
${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION
+ ${CMAKE_INSTALL_BINDIR}
COMPONENT
${PROJECT_NAME})