aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Ates <joseph.ates@msasafety.com>2015-11-12 13:09:36 -0500
committerAndreas Schneider <asn@cryptomilk.org>2015-12-18 12:21:35 +0100
commit9a120731ec3831c68bfa88b719395f3ea8a24f54 (patch)
treeb64059a79b5d4fff8fa582d0d1753bbd742812f7 /tests/CMakeLists.txt
parent443b02803dd35f34f6823e31791bc85fc07b9629 (diff)
downloadcmocka-9a120731ec3831c68bfa88b719395f3ea8a24f54.tar.gz
cmocka-9a120731ec3831c68bfa88b719395f3ea8a24f54.tar.xz
cmocka-9a120731ec3831c68bfa88b719395f3ea8a24f54.zip
tests: Add test for call ordering functionality
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2f985a5..faaa604 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -16,7 +16,9 @@ set(CMOCKA_TESTS
test_exception_handler
test_basics
test_skip
- test_setup_fail)
+ test_setup_fail
+ test_ordering
+ test_ordering_fail)
foreach(_CMOCKA_TEST ${CMOCKA_TESTS})
add_cmocka_test(${_CMOCKA_TEST} ${_CMOCKA_TEST}.c ${CMOCKA_STATIC_LIBRARY})
@@ -46,6 +48,14 @@ set_tests_properties(
"\\[ FAILED \\] 1 test"
)
+# test_ordering ensure proper failures
+set_tests_properties(
+ test_ordering_fail
+ PROPERTIES
+ PASS_REGULAR_EXPRESSION
+ "\\[ FAILED \\] 7 test"
+)
+
# test_exception_handler
if (WIN32)
set_tests_properties(