aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2016-02-10 12:00:36 +0100
committerAndreas Schneider <asn@cryptomilk.org>2016-02-10 12:00:36 +0100
commit9fc415a88f99b881b5c9f4c227c4967fd92d292a (patch)
treeb9fcad26d9a84cea3db15e8db36221fd7f6d8462 /tests/CMakeLists.txt
parent56ed9b0eb533ea38825c1be570f48334d1e457f0 (diff)
downloadcmocka-9fc415a88f99b881b5c9f4c227c4967fd92d292a.tar.gz
cmocka-9fc415a88f99b881b5c9f4c227c4967fd92d292a.tar.xz
cmocka-9fc415a88f99b881b5c9f4c227c4967fd92d292a.zip
tests: Add a group setup assert test
Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index faaa604..4b015ba 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -8,6 +8,7 @@ include_directories(
set(CMOCKA_TESTS
test_alloc
+ test_group_setup_assert
test_group_setup_fail
test_fixtures
test_group_fixtures
@@ -80,6 +81,13 @@ set_tests_properties(
)
set_tests_properties(
+ test_group_setup_assert
+ PROPERTIES
+ WILL_FAIL
+ 1
+)
+
+set_tests_properties(
test_group_setup_fail
PROPERTIES
WILL_FAIL