aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorStas Kobzar <stas@modulis.ca>2017-04-04 11:06:15 -0400
committerAndreas Schneider <asn@cryptomilk.org>2017-04-05 08:40:50 +0200
commitfcad5ab7232a1b556580459e4f46e653ccef969b (patch)
tree24d06651d79e4a9af0d2517e4cd606c94b2913b2 /tests/CMakeLists.txt
parent30590636487cb976a7ad850024abb16a5f44a320 (diff)
downloadcmocka-fcad5ab7232a1b556580459e4f46e653ccef969b.tar.gz
cmocka-fcad5ab7232a1b556580459e4f46e653ccef969b.tar.xz
cmocka-fcad5ab7232a1b556580459e4f46e653ccef969b.zip
Fix TAP output and summary.
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt26
1 files changed, 13 insertions, 13 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 68ae4ac..b1380de 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -153,21 +153,21 @@ set(TEST_OUTPUT_FMTS
xml)
set(test_basics_tap_out
- "^\t1\\.\\.2"
- "\tok 1 - null_test_success"
- "\tok 2 - int_test_success"
- "ok - tests")
+ "^1\\.\\.2"
+ "ok 1 - null_test_success"
+ "ok 2 - int_test_success"
+ "# ok - tests")
set(test_assert_macros_fail_tap_out
- "^\t1\\.\\.1"
- "\tnot ok 1 - test_assert_return_code_fail"
- "\t#[^\n\r]+[\n\r]\t#[^\n\r]+[\n\r]not ok - tests")
+ "^1\\.\\.1"
+ "not ok 1 - test_assert_return_code_fail"
+ "#[^\n\r]+[\n\r]#[^\n\r]+[\n\r]# not ok - tests")
set(test_groups_tap_out
- "^\t1\\.\\.1"
- "\tok 1 - null_test_success"
- "ok - test_group1"
- "\t1\\.\\.1"
- "\tok 1 - int_test_success"
- "ok - test_group2")
+ "^1\\.\\.1"
+ "ok 1 - null_test_success"
+ "# ok - test_group1"
+ "1\\.\\.1"
+ "ok 1 - int_test_success"
+ "# ok - test_group2")
set(test_skip_tap_out
"not ok 1 # SKIP")
set(test_setup_fail_tap_out