aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@samba.org>2014-01-20 23:34:54 +0100
committerAndreas Schneider <asn@samba.org>2014-01-20 23:34:54 +0100
commit980a30d0a96ca22ee47aa60eb8504c77eae232b5 (patch)
tree9632b89e5429951cca7eac9b5121cae6c8a06c03 /CMakeLists.txt
parentde86e64888556301ea5fbed99da887772640a58c (diff)
downloadsocket_wrapper-980a30d0a96ca22ee47aa60eb8504c77eae232b5.tar.gz
socket_wrapper-980a30d0a96ca22ee47aa60eb8504c77eae232b5.tar.xz
socket_wrapper-980a30d0a96ca22ee47aa60eb8504c77eae232b5.zip
cmake: Add cmake config version script.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52c8e77..134960a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,17 @@ install(
pkgconfig
)
+# cmake config files
+configure_file(socket_wrapper-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/socket_wrapper-config-version.cmake @ONLY)
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/socket_wrapper-config-version.cmake
+ DESTINATION
+ ${CMAKE_INSTALL_DIR}
+ COMPONENT
+ devel
+)
+
# check subdirectories
add_subdirectory(src)