aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-05-28 14:53:40 +0200
committerAndreas Schneider <asn@cryptomilk.org>2013-05-28 14:53:40 +0200
commita0a8ea66722ff75109eecb12a48b2487f103142a (patch)
treec5a622d83aeb69ee26c791b2b74ee6646d176eaf /CMakeLists.txt
parent48d46cac3f21805eedc39a53cb224735c46ab77a (diff)
downloadsocket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.tar.gz
socket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.tar.xz
socket_wrapper-a0a8ea66722ff75109eecb12a48b2487f103142a.zip
tests: Add test as cmocka test.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c047947..e89ac84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,3 +49,9 @@ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
# check subdirectories
add_subdirectory(src)
+
+if (WITH_TESTING)
+ find_package(CMocka REQUIRED)
+ include(AddCMockaTest)
+ add_subdirectory(tests)
+endif (WITH_TESTING)