aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@samba.org>2014-01-20 23:33:18 +0100
committerAndreas Schneider <asn@samba.org>2014-01-20 23:33:18 +0100
commitde86e64888556301ea5fbed99da887772640a58c (patch)
treebe3c3590a808ed604b853519ab7e0b00f2985ea9 /CMakeLists.txt
parentd78b20d999b0b26f9119dcd6430cbea595756f07 (diff)
downloadsocket_wrapper-de86e64888556301ea5fbed99da887772640a58c.tar.gz
socket_wrapper-de86e64888556301ea5fbed99da887772640a58c.tar.xz
socket_wrapper-de86e64888556301ea5fbed99da887772640a58c.zip
cmake: Add pkg-config file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50674ba..52c8e77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,17 @@ find_package(Threads)
include(ConfigureChecks.cmake)
configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+# pkg-config file
+configure_file(socket_wrapper.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/socket_wrapper.pc @ONLY)
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/socket_wrapper.pc
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig
+ COMPONENT
+ pkgconfig
+)
+
# check subdirectories
add_subdirectory(src)