aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnoop C S <anoopcs@redhat.com>2016-08-22 19:37:47 +0530
committerAndreas Schneider <asn@samba.org>2016-08-23 16:27:58 +0200
commit17cfdc6a6568f0dbc34d863ad2d80acaed15a6ad (patch)
treed2aa9539fbb17d7c89e32a96799ff482663af972 /tests/CMakeLists.txt
parent04dacf2d2e764eb9fd0791642893b4e1bc199ef0 (diff)
downloadsocket_wrapper-17cfdc6a6568f0dbc34d863ad2d80acaed15a6ad.tar.gz
socket_wrapper-17cfdc6a6568f0dbc34d863ad2d80acaed15a6ad.tar.xz
socket_wrapper-17cfdc6a6568f0dbc34d863ad2d80acaed15a6ad.zip
swrap: Add test case to validate oldfd = newfd case in dup2()
Signed-off-by: Anoop C S <anoopcs@redhat.com> Reviewed-by: Michael Adam <obnox@samba.org> Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index aecf6b8..9b5c4bf 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -21,6 +21,7 @@ target_link_libraries(${TORTURE_LIBRARY}
set(SWRAP_TESTS
test_ioctl
test_tcp_listen
+ test_tcp_dup2
test_echo_tcp_socket
test_echo_tcp_connect
test_echo_tcp_bind