aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnoop C S <anoopcs@redhat.com>2018-01-31 22:43:21 +0530
committerAndreas Schneider <asn@samba.org>2018-05-02 16:31:42 +0200
commit1ff35b6bb9a2702c4b0785281f22018b05e549c8 (patch)
treecc7eac84e76e78ef1148e8e5a4ccbe6e5399ae27 /tests/CMakeLists.txt
parentda1fe44b27ce2dc66d795637c13bc13b2a657b79 (diff)
downloadsocket_wrapper-1ff35b6bb9a2702c4b0785281f22018b05e549c8.tar.gz
socket_wrapper-1ff35b6bb9a2702c4b0785281f22018b05e549c8.tar.xz
socket_wrapper-1ff35b6bb9a2702c4b0785281f22018b05e549c8.zip
tests: Add test case to validate free-list indexes
Signed-off-by: Anoop C S <anoopcs@redhat.com> Reviewed-by: Michael Adam <obnox@samba.org> Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 08abcad..26173bb 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -42,7 +42,8 @@ set(SWRAP_TESTS
test_thread_echo_tcp_connect
test_thread_echo_tcp_write_read
test_thread_echo_tcp_sendmsg_recvmsg
- test_thread_echo_udp_send_recv)
+ test_thread_echo_udp_send_recv
+ test_tcp_socket_overwrite)
if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd)