aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2014-05-14 10:11:37 +0200
committerMichael Adam <obnox@samba.org>2014-05-22 12:05:37 +0200
commit6f96c9df7cdc2e4b80bad9cd782a9256e1f03625 (patch)
treed498906bf0a498c4d1fe9c958565ca9cc560e8f0 /tests/CMakeLists.txt
parentd71c5d60d54048fe649be332b4267d93ae19d7ce (diff)
downloadsocket_wrapper-6f96c9df7cdc2e4b80bad9cd782a9256e1f03625.tar.gz
socket_wrapper-6f96c9df7cdc2e4b80bad9cd782a9256e1f03625.tar.xz
socket_wrapper-6f96c9df7cdc2e4b80bad9cd782a9256e1f03625.zip
tests: Add support to receive IP_PKTINFO in echo_srv.
Signed-off-by: Andreas Schneider <asn@cryptomilk.org> Reviewed-by: Michael Adam <obnox@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 94e92c1..287539b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -6,6 +6,7 @@ include_directories(
${CMOCKA_INCLUDE_DIR}
)
+add_definitions(-D_GNU_SOURCE)
set(TORTURE_LIBRARY torture)
# RFC862 echo server