aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@samba.org>2018-10-24 08:44:19 +0200
committerAndreas Schneider <asn@samba.org>2018-10-30 10:50:49 +0100
commit916ce9c66576f4de24dfe774fe9ab094187c1462 (patch)
treed9865285a179feee189711d55e0bdaec5ce35292 /tests/CMakeLists.txt
parent32df6eb3c0d6ef19f561ff65e444b3ce3dff5a9e (diff)
downloadsocket_wrapper-916ce9c66576f4de24dfe774fe9ab094187c1462.tar.gz
socket_wrapper-916ce9c66576f4de24dfe774fe9ab094187c1462.tar.xz
socket_wrapper-916ce9c66576f4de24dfe774fe9ab094187c1462.zip
cmake: Don't use string PREPEND
This is only supported in cmake >= 3.10. Signed-off-by: Andreas Schneider <asn@samba.org> Reviewed-by: Stefan Metzmacher <metze@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3578f76..b43d03c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -83,8 +83,8 @@ function(ADD_CMOCKA_TEST_ENVIRONMENT _TEST_NAME)
if (OSX)
set(TORTURE_ENVIRONMENT "DYLD_FORCE_FLAT_NAMESPACE=1;DYLD_INSERT_LIBRARIES=${SOCKET_WRAPPER_LOCATION}")
else ()
- string(REPLACE ";" ":" TORTURE_ENVIRONMENT "${PRELOAD_LIBRARIES}")
- string(PREPEND TORTURE_ENVIRONMENT "LD_PRELOAD=")
+ string(REPLACE ";" ":" _TMP_ENV "${PRELOAD_LIBRARIES}")
+ set(TORTURE_ENVIRONMENT "LD_PRELOAD=${_TMP_ENV}")
endif()
set_property(TEST