aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnoop C S <anoopcs@redhat.com>2018-11-10 10:57:27 +0530
committerAndreas Schneider <asn@samba.org>2018-11-12 11:03:43 +0100
commitd788cef44dc998ce51aeb9637145bf1d1cd58a9b (patch)
tree4155e89efcd708f1555bcf435fe3ea883da34248 /tests/CMakeLists.txt
parenta2d7735ac7e8c3e9da15b6642c4f6e832ad7fa4d (diff)
downloadsocket_wrapper-d788cef44dc998ce51aeb9637145bf1d1cd58a9b.tar.gz
socket_wrapper-d788cef44dc998ce51aeb9637145bf1d1cd58a9b.tar.xz
socket_wrapper-d788cef44dc998ce51aeb9637145bf1d1cd58a9b.zip
tests: Enable threaded test cases on FreeBSD
It was previously judged as a bug which now turned to be due to wrong backlog count set in echo_srv while listening on socket. Signed-off-by: Anoop C S <anoopcs@redhat.com> Reviewed-by: Andreas Schneider <asn@samba.org> Reviewed-by: Ralph Boehme <slow@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 829c243..1da839c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -107,18 +107,6 @@ foreach(_SWRAP_TEST ${SWRAP_TESTS})
add_cmocka_test_environment(${_SWRAP_TEST})
endforeach()
-# These test will fail on because there is a threading race condition in
-# FreeBSD.
-# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231848
-if (FREEBSD)
- set_tests_properties(test_thread_echo_tcp_connect
- PROPERTIES DISABLED TRUE)
- set_tests_properties(test_thread_echo_tcp_write_read
- PROPERTIES DISABLED TRUE)
- set_tests_properties(test_thread_echo_tcp_sendmsg_recvmsg
- PROPERTIES DISABLED TRUE)
-endif()
-
if (HELGRIND_TESTING)
find_program(VALGRIND_EXECUTABLE valgrind)
if (VALGRIND_EXECUTABLE)