aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@samba.org>2014-01-21 09:52:06 +0100
committerAndreas Schneider <asn@samba.org>2014-01-21 09:52:06 +0100
commite5df09bb2b7aaeef0d3127ad85371eab78702060 (patch)
tree455457ed8f5087d023d19a630c06cab2ce234f51 /tests/CMakeLists.txt
parentb6161d0d94822608053de73b12600661daefabc7 (diff)
downloadsocket_wrapper-e5df09bb2b7aaeef0d3127ad85371eab78702060.tar.gz
socket_wrapper-e5df09bb2b7aaeef0d3127ad85371eab78702060.tar.xz
socket_wrapper-e5df09bb2b7aaeef0d3127ad85371eab78702060.zip
cmake: Only build test_sendmsg_recvmsg_fd if we have msg_control.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index c626c02..53d458c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -25,8 +25,11 @@ set(SWRAP_TESTS
test_echo_tcp_writev_readv
test_echo_udp_sendto_recvfrom
test_echo_udp_send_recv
- test_echo_udp_sendmsg_recvmsg
- test_sendmsg_recvmsg_fd)
+ test_echo_udp_sendmsg_recvmsg)
+
+if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
+ set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd)
+endif (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
foreach(_SWRAP_TEST ${SWRAP_TESTS})
add_cmocka_test(${_SWRAP_TEST} ${_SWRAP_TEST}.c ${TORTURE_LIBRARY})